Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issue Adding Addresses in Twilio Console
Incident Report for Twilio
Resolved
The issue with not being able to add addresses in the Twilio Console for regulatory purposes has been resolved and the Twilio Console is operating normally at this time.
Posted Dec 02, 2021 - 14:42 PST
Monitoring
We are observing recovery with the ability to add addresses for regulatory purposes through the Twilio Console. We will continue to monitor for system stability. We’ll provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 02, 2021 - 13:43 PST
Investigating
We are currently seeing degraded performance in the Twilio Console, with a subset of Twilio customers encountering a blank screen when attempting to add addresses for regulatory purposes. The blank screen is indicative that the address could not be created. Our engineering team is looking into the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 02, 2021 - 13:00 PST
Update
We are observing recovery with the ability to add addresses for regulatory purposes through the Twilio Console. We will continue to monitor for system stability. We’ll provide another update in 30 mins or as soon as more information becomes available.
Posted Dec 02, 2021 - 12:28 PST
Monitoring
We are observing recovery with the ability to add addresses for regulatory purposes through the Twilio Console. We will continue to monitor for system stability. We’ll provide another update in 30 mins or as soon as more information becomes available.
Posted Dec 02, 2021 - 11:42 PST
Update
We are currently seeing degraded performance in the Twilio Console, with a subset of Twilio customers encountering a blank screen when attempting to add addresses for regulatory purposes. The blank screen is indicative that the address could not be created. Our engineering team is looking into the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 02, 2021 - 10:49 PST
Investigating
We’ve become aware of a potential issue when adding addresses in the Twilio Console for regulatory purposes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Dec 02, 2021 - 10:24 PST
This incident affected: DEVELOPER TOOLS (Console).