Following the successful outcome of the initial Maintenance 14 June 14:00 until 14 June 21:00 PDT, this additional backup date is no longer required and is being removed. Thank you.
Posted Jun 14, 2024 - 21:47 PDT
Update
Following the successful outcome of the initial Maintenance 14 June 14:00 until 14 June 21:00 PDT, this additional backup date is no longer required and is being removed. Thank you.
Posted Jun 14, 2024 - 21:43 PDT
Update
Following the successful outcome of the initial Maintenance 15 June 16:00 until 15 June 21:00 PDT, this additional backup date is no longer required and is being removed. Thank you.
Posted Jun 14, 2024 - 21:39 PDT
Scheduled
Twilio is conducting planned maintenance from 15 June 16:00 until 15 June 21:00 PDT on the Twilio Network. During the maintenance window, there could be intermittent impact to Verify Silent Network Auth and Lookup services in Europe.
Posted May 14, 2024 - 16:07 PDT
This scheduled maintenance affected: ACCOUNT SECURITY (Verify, Lookup) and CARRIER NETWORK (Lookup Identity Match, Lookup Line Type Intelligence [Twilio API], Lookup SIM Swap).