Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Latency and Timeout Errors with Twilio Rest API
      Incident Report for Twilio
      Resolved
      Changes made with our cloud provider's networking appliance has resolved the API timeouts and Twilio Console issues. The Rest API and Console are operating normally at this time.
      Posted Aug 31, 2020 - 13:24 PDT
      Monitoring
      We have made changes to mitigate the elevated API timeouts and Twilio Console issues. We will continue to monitor the situation for the next 30 minutes before we mark the incident as fully resolved.
      Posted Aug 31, 2020 - 12:51 PDT
      Identified
      We have identified the elevated API timeouts to be an issue with a cloud provider's networking appliance. Twilio Engineering is actively working with our cloud provider to resolve this issue. We will provide another update within 60 minutes or sooner as more information becomes available.
      Posted Aug 31, 2020 - 12:07 PDT
      Update
      Twilio REST API continues to experience elevated timeout errors, with 20% of all REST API traffic across all products as well as Twilio Console. We are actively working with our cloud provider to resolve the issue. We will provide another update within 60 mins or sooner as more information becomes available.
      Posted Aug 31, 2020 - 11:13 PDT
      Update
      Twilio REST API continues to experience elevated timeout errors. We are actively working with our network provider to investigate the issue. The issue is impacting multiple REST API products and customers may also have trouble accessing Twilio Console. We will provide another update in 30 minutes or sooner as more information becomes available.
      Posted Aug 31, 2020 - 10:37 PDT
      Update
      We are currently investigating an issue with latency and timeout errors on Twilio's Rest API. Multiple products are impacted. Our engineers are working on the issue, and we will provide another update when more information becomes available.
      Posted Aug 31, 2020 - 10:01 PDT
      Update
      We are continuing to investigate this issue.
      Posted Aug 31, 2020 - 09:31 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Aug 31, 2020 - 09:12 PDT
      This incident affected: DEVELOPER TOOLS (Console, REST API).