Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Report Delays when sending to US Verizon on Twilio Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing delivery status delays when sending SMS to US Verizon for Twilio Short Codes. This incident has been resolved.
Posted Oct 15, 2020 - 11:08 PDT
Investigating
We are experiencing delays in receiving message delivery reports when sending SMS to US Verizon for a small subset of Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 15, 2020 - 10:59 PDT
This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).