Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Increased Delay for Super SIM Attaching to Networks in Some Countries
      Incident Report for Twilio
      Resolved
      The issues causing an increased delay for Super SIMs attaching to networks has been resolved.
      Posted Aug 06, 2020 - 18:48 PDT
      Update
      There is an ongoing network issue where Super SIMs in some countries may take longer to connect. These devices may need to switch their IMSI which can take up to three minutes. Our engineers continue to investigate and an additional update will be provided in the next 60 minutes.
      Posted Aug 06, 2020 - 17:56 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Aug 06, 2020 - 17:41 PDT