Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Requests Failed Due to a Downstream Latency Issues in Flex
      Incident Report for Twilio
      Resolved
      Some requests to create channels in Flex failed due to downstream latency has been resolved, and is operating normally at this time.
      Posted Sep 22, 2023 - 13:17 PDT
      Update
      We are investigating delays in billing for Flex. We expect to provide another update in 1 hour or as soon as more information becomes available
      Posted Sep 22, 2023 - 13:10 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Flex (billing). Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 22, 2023 - 12:46 PDT
      This incident affected: FLEX (Flex Billing).