Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
US Toll Free and Subset of US Long Code Numbers Experiencing Inbound and Outbound SMS and MMS Delivery Delays to/from US and Canada Networks
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays for SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes. This incident has been resolved.
Posted Jan 14, 2022 - 19:48 PST
Monitoring
We are observing full recovery in SMS delivery delays for SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes. We are also seeing recovery for delivery receipts. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 14, 2022 - 17:46 PST
Update
We continue to see recovery in which SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes are being delivered. We are still seeing delivery receipts being delayed, with delivery status stuck at "Sent". Our engineering team has implemented a workaround for the delayed delivery receipts and we are seeing some recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 14, 2022 - 15:52 PST
Update
We continue to see recovery in which SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes are being delivered. We are still seeing delivery receipts being delayed, with delivery status stuck at "Sent". Our engineering team is implementing a workaround for the delayed delivery receipts. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 14:57 PST
Update
We continue to see recovery in which SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes are being delivered. We are still seeing delivery receipts being delayed, with delivery status stuck at "Sent". Our engineering team is continuing to work with our carrier partner to fully resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 13:57 PST
Update
We are now observing recovery in which SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes are being delivered. We are still seeing delivery receipts being delayed, with delivery status stuck at "Sent". Our engineering team is continuing to work with our carrier partner to fully resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 12:59 PST
Update
While we've observed noticeable recovery after the implementation of the workaround, we continue to see intermittent delivery delays sending and receiving Toll Free SMS and MMS messages in US and Canada, along with a small subset of T-mobile traffic on US long codes. The issue is also causing delivery receipts to be delayed, with delivery status stuck at "Sent". Our engineering team is continuing to work with our carrier partner to fully resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 12:03 PST
Update
We are continuing our investigation and have discovered message delivery reports (DLRs) are also affected by this issue and experiencing delays for SMS and MMS messages to/from US and Canada networks from US Toll-Free number and some US long codes.
Posted Jan 14, 2022 - 10:54 PST
Update
We are continuing our investigation and have discovered a portion of US long codes are also experiencing delivery delays when sending SMS and MMS to US and Canada networks.
Posted Jan 14, 2022 - 09:20 PST
Identified
We are now observing some recovery in which some SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes are being delivered. Our engineers have identified the issue and implemented a workaround for older messages. However, message DLRs will continue to be delayed even while messages are getting delivered. Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 14, 2022 - 08:53 PST
Update
We are continuing our investigation and have discovered inbound traffic to Twilio Toll-Free numbers from US and Canada networks is also affected and experiencing delivery delays. In addition, we have discovered a small portion of US long code numbers are affected and also experiencing SMS and MMS delivery delays for inbound and outbound traffic to/from US and Canada networks. Our engineers continue working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 14, 2022 - 06:51 PST
Update
We are continuing our investigation and have discovered MMS messages are also affected by this issue and experiencing delivery delays when sent to US and Canada networks using Toll-Free numbers.
Posted Jan 14, 2022 - 06:29 PST
Investigating
We are experiencing delivery delays when sending SMS and MMS messages to US and Canada networks using Toll-free numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 05:56 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Toll-Free, North America, MMS Toll-Free, SMS Delivery Notifications & Status Callbacks).