Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to MTN in South Africa
      Incident Report for Twilio
      Resolved
      The issue was resolved. The SMS delivery is back to normal to MTN in South Africa.
      Posted Mar 27, 2020 - 09:05 PDT
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will provide more updates as soon as they become available.
      Posted Mar 27, 2020 - 08:29 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to MTN network in South Africa. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Mar 27, 2020 - 06:43 PDT