Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays receiving message status events for messages sent to Verizon US handsets via toll-free numbers
      Incident Report for Twilio
      Resolved
      We have confirmed the full recovery of issues related receiving message status events for messages sent to Verizon US handsets via toll-free numbers. Service has been restored.
      Posted Jul 15, 2019 - 03:24 PDT
      Monitoring
      We are seeing recovery in receiving message status events for messages sent to Verizon US handsets via toll-free numbers. We will continue to monitor to ensure a full recovery.
      Posted Jul 15, 2019 - 02:15 PDT
      Investigating
      We are again experiencing issues receiving message status events for messages sent to Verizon US handsets via US/CA toll-free numbers. As we stated previously, the impact is for message status events alone and does not have any impact on receiving messages. We will continue to work with our carrier partner to resolve this issue.
      Posted Jul 15, 2019 - 00:14 PDT
      Monitoring
      We are seeing recovery in receiving message status events for messages sent to Verizon US handsets via toll-free numbers. We will continue to monitor to ensure a full recovery.
      Posted Jul 14, 2019 - 23:19 PDT
      Update
      We are continuing to experience issues receiving message status events for messages sent to Verizon US handsets via US/CA toll-free numbers. The impact is for message status events alone and does not have any impact on sending or receiving the messages. We will continue to work with our carrier partner to resolve this issue.
      Posted Jul 14, 2019 - 20:51 PDT
      Investigating
      We are experiencing issues receiving message status events for messages sent to Verizon US handsets via US/CA toll-free numbers. The messages themselves are being delivered. The impact is for message status events alone and does not have any impact on receiving messages. We will continue to work with our carrier partner to resolve this issue.
      Posted Jul 14, 2019 - 18:44 PDT
      This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).