Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures to U.S. Carriers via a Subset of Twilio Toll-Free Numbers
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery failures when sending from a subset of Twilio toll-free numbers to multiple U.S. carriers. This incident has been resolved.
Posted Sep 13, 2021 - 13:42 PDT
Update
We continue to experience intermittent SMS delivery failures when sending from a subset of Twilio toll-free numbers to multiple U.S. carriers. Our engineers are still working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 13, 2021 - 11:41 PDT
Update
We are experiencing intermittent SMS delivery failures when sending from a subset of Twilio toll-free numbers to multiple U.S. carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 13, 2021 - 10:50 PDT
Investigating
We've become aware of a potential issue with increased SMS delivery failures via a subset of Twilio toll-free numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 13, 2021 - 10:27 PDT
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).