Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound MMS delays towards US Short Codes
Incident Report for Twilio
Resolved
We are no longer seeing MMS delays towards a subset of Twilio US Short Codes. This incident has been resolved.
Posted Oct 18, 2019 - 09:12 PDT
Identified
The issue has been identified and we are working with our carrier partners on a fix and will provide an update as soon as we have further information.
Posted Oct 18, 2019 - 08:32 PDT
Update
We continue to experience issues receiving inbound MMS messages sent from mobile devices in the US to a subset of Twilio US short codes. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information
Posted Oct 18, 2019 - 07:03 PDT
Investigating
We are not currently receiving inbound MMS messages sent from mobile devices in the US to a subset of Twilio US short codes. We are also experiencing delays in receiving status callbacks for outbound MMS messages sent from Twilio's US short codes to mobile devices; actual delivery of outbound MMS messages are unaffected. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted Oct 18, 2019 - 03:24 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).