Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Issues to US T-Mobile over Toll-Free
Incident Report for Twilio
Resolved
We are no longer seeing delays receiving status events for SMS sent from US Toll-Free to US T-Mobile handsets. This incident has been resolved.
Posted Oct 21, 2019 - 05:22 PDT
Investigating
We have detected delays in receiving message status events for some SMS sent from US Toll-Free to US T-Mobile handsets. There is no impact to actual message delivery. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Oct 21, 2019 - 03:58 PDT
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).