Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Mexico Customers Unable to Activate Their Accounts

        Incident Report for Twilio

        Resolved

        We are closing this incident as it is being tracked under a duplicate incident. For any further updates, please refer to the following incident page: https://status.twilio.com/incidents/sgl34l18tvsy
        Posted Apr 08, 2026 - 20:13 PDT

        Investigating

        We are currently investigating an issue where some customers in Mexico using USD currency may experience problems with their account balance not updating successfully. This may result in account suspension and prevent activation. Our engineering team is actively investigating this issue. We will provide another update within 1 hour or as soon as more information becomes available. Thank you for your patience.
        Posted Apr 08, 2026 - 19:07 PDT
        This incident affected: TWILIO PLATFORM (Billing).