Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Stale message list in Console for some customers
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 7 months ago. Jul 16, 2018 - 14:06 PDT
Identified
We have identified the cause for the issue. Our engineers are working on a resolution. Customers may still see stale message lists with a delay of approximately 10 minutes. We will post another update in 1 hour
Posted 7 months ago. Jul 16, 2018 - 13:01 PDT
Investigating
Some customers may see stale message lists in Console. This issue is not impacting message delivery. Our engineering team is working on resolving the issue. We will provide another update in 1 hour.
Posted 7 months ago. Jul 16, 2018 - 11:56 PDT
This incident affected: TWILIO PLATFORM (Console).