Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Duplicate SMS and Delayed Delivery to a Small Subset of Twilio UK Numbers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing duplicate SMS delivery and delays when receiving messages from UK numbers to small subset of Twilio UK numbers. This incident has been resolved.
      Posted Feb 24, 2021 - 05:42 PST
      Monitoring
      We are observing recovery on duplicate SMS delivery and delays when receiving messages from UK numbers to small subset of Twilio UK numbers. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 24, 2021 - 03:52 PST
      Update
      We are continuing to experience duplicate SMS delivery and delays when receiving messages from UK numbers to small subset of Twilio UK numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Feb 24, 2021 - 01:07 PST
      Update
      We are experiencing duplicate SMS delivery and delays when receiving messages from UK numbers to small subset of Twilio UK numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Feb 23, 2021 - 21:07 PST
      Update
      We are experiencing duplicate SMS delivery and delays when receiving messages from UK numbers to small subset of Twilio UK numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 120 minutes or as soon as more information becomes available.
      Posted Feb 23, 2021 - 18:43 PST
      Update
      We are experiencing duplicate SMS delivery and delays when receiving messages from UK numbers to small subset of Twilio UK numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 60 minutes or as soon as more information becomes available.
      Posted Feb 23, 2021 - 17:48 PST
      Investigating
      Our monitoring systems have detected a potential issue with programmable messaging for subset of our UK numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Feb 23, 2021 - 17:27 PST
      This incident affected: CARRIER NETWORK (SMS, Europe).