Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Channel Migration API Issue
      Incident Report for Twilio
      Resolved
      We are no longer experiencing issues with Programmable Chat Channel Migration API. This incident has been resolved.
      Posted May 10, 2022 - 19:44 PDT
      Update
      Programmable Chat Channel Migration API is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
      Posted May 10, 2022 - 17:51 PDT
      Update
      Programmable Chat Channel Migration API is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
      Posted May 10, 2022 - 15:50 PDT
      Monitoring
      Programmable Chat Channel Migration API is now operating normally. We will continue to monitor for system stability. We'll provide another update in 60 minutes or as soon as more information becomes available.
      Posted May 10, 2022 - 14:55 PDT
      Update
      Our engineers have identified the root cause for the Programmable Chat Channel Migration API issue and are currently working on the resolution. Using this API to migrate multiple channels will cause an inflated concurrency count and could cause you to receive 429 errors when using other Twilio APIs. In the meantime, you can work around this by only using the API in a single thread. We will provide another update in 24 hours or as soon as we learn more.
      Posted May 10, 2022 - 10:32 PDT
      Update
      Our Engineers have identified an issue with how concurrency is being tracked at our edge when using the Programmable Chat Channel Migration API. Using this API to migrate multiple channels will cause an inflated concurrency count and could cause you to receive 429 errors when using other Twilio APIs. Our engineering team is still investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by only using the API in a single thread. We will provide another update in 24 hours or as soon as we have new information.
      Posted May 09, 2022 - 14:03 PDT
      Update
      Our Engineers have identified an issue with the Programmable Chat Channel Migration API that affects customers trying to use many threads simultaneously to migrate many channels. Our engineering team is still investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by only using the API in a single thread. We will provide another update in 24 hours or as soon as we have new information.
      Posted May 09, 2022 - 14:02 PDT
      Update
      Our Engineers have identified an issue with how concurrency is being tracked at our edge when using the Programmable Chat Channel Migration API. Using this API to migrate multiple channels will cause an inflated concurrency count and could cause you to receive 429 errors when using other Twilio APIs. Our engineering team is still investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by only using the API in a single thread. We will provide another update in 24 hours or as soon as we have new information.
      Posted May 09, 2022 - 13:21 PDT
      Update
      Our Engineers have identified an issue with how concurrency is being tracked at our edge when using the Programmable Chat Channel Migration API. Using this API to migrate multiple channels will cause an inflated concurrency count and could cause you to receive 429 errors when using other Twilio APIs. Our engineering team is still investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by only using the API in a single thread. We will provide another update in 24 hours or as soon as we have new information.
      Posted May 09, 2022 - 10:32 PDT
      Update
      Our Engineers have identified an issue with the Programmable Chat Channel Migration API that affects customers trying to use many threads simultaneously to migrate many channels. Our engineering team is still investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by only using the API in a single thread. We will provide another update in 24 hours or as soon as we have new information.
      Posted May 09, 2022 - 08:29 PDT
      Update
      We have identified an issue with the Programmable Chat Channel Migration API that affects customers trying to use many threads simultaneously to migrate many channels. Our engineering team is still investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by issue only using the API in a single thread. We will provide another update in 24 hours or as soon as we learn more
      Posted May 08, 2022 - 08:28 PDT
      Update
      We have identified an issue with the Programmable Chat Channel Migration API that affects customers trying to use many threads simultaneously to migrate many channels. Our engineering team is still investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by issue only using the API in a single thread. We will provide another update in 24 hours or as soon as we learn more
      Posted May 07, 2022 - 10:53 PDT
      Update
      We have identified an issue with the Programmable Chat Channel Migration API that affects customers trying to use many threads simultaneously to migrate many channels. Our engineering team is currently investigating the root cause of this issue, however it may be a few days before a resolution is discovered. In the meantime, you can work around this by issue only using the API in a single thread. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted May 06, 2022 - 10:59 PDT
      Identified
      We have identified an issue with the Programmable Chat Channel Migration API that affects customers trying to use many threads simultaneously to migrate many channels. We are currently working on a resolution. In the meantime, you can work around this by issue only using the API in a single thread. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 06, 2022 - 09:02 PDT
      Investigating
      We have identified an issue with the Programmable Chat Channel Migration API that affects customers trying to use many threads simultaneously to migrate many channels. We are currently working on a resolution. In the meantime, you can work around this by issue only using the API in a single thread. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 06, 2022 - 08:19 PDT
      This incident affected: DEVELOPER TOOLS (REST API).