Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Glo Mobile in Nigeria
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays to Glo Mobile Network in Nigeria. This incident has been resolved.
Posted Feb 18, 2021 - 15:30 PST
Monitoring
We are observing recovery in delivery delays when sending SMS to Glo Mobile Network in Nigeria from Twilio numbers. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 18, 2021 - 14:57 PST
Update
We continue to experience SMS delivery delays when sending messages to the Glo Mobile Network in Nigeria. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 2 hours as soon as we have additional information.
Posted Feb 18, 2021 - 13:25 PST
Investigating
We are experiencing SMS delivery delays when sending messages to the Glo Mobile Network in Nigeria. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 1 hour as soon as we have additional information.
Posted Feb 18, 2021 - 12:27 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).