Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Receiving calls failing to some Belgium numbers.
Incident Report for Twilio
Resolved
The issue of failure to receive calls for some Belgium numbers has been resolved and all systems are operating normally.
Posted 6 months ago. Feb 12, 2019 - 03:30 PST
Investigating
We have detected an increase in failures for receiving calls to some Twilio phone numbers in Belgium. Our engineers are working with our carrier partner to resolve this issue and will provide more information as soon as available.
Posted 6 months ago. Feb 12, 2019 - 02:56 PST
This incident affected: CARRIER NETWORK (Voice, Europe).