Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Receipt Delays to T-Mobile Network in the US
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery receipt messages over a subset of short codes to T-Mobile network in the US. This incident has been resolved.
      Posted Aug 03, 2022 - 16:04 PDT
      Monitoring
      We are observing recovery in SMS delivery receipt messages over a subset of short codes to T-Mobile network in the US. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 14:11 PDT
      Update
      We are still experiencing some delivery receipt delays over a subset of short codes to T-Mobile network in the US. Our engineers continue working with our carrier partner to fully resolve the issue to ensure the service gets completely resolved. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 10:15 PDT
      Update
      We continue experiencing some delivery receipt delays over a subset of short codes to T-Mobile network in the US. Our engineers are working with our carrier partner to fully resolve the issue to ensure the service get completely resolved. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 08:08 PDT
      Identified
      After some hours of monitoring, we are still experiencing some delivery receipt delays over a subset of short codes to T-Mobile network in the US. Our engineers are working with our carrier partner to fully resolve the issue to ensure the service get completely resolved. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 03, 2022 - 07:05 PDT
      Update
      We are still observing recovery in SMS delivery receipt messages over a subset of short codes to T-Mobile network in the US. We will continue monitoring the service for some time to ensure a full recovery. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 22:52 PDT
      Update
      We are still observing recovery in SMS delivery receipt messages over a subset of short codes to T-Mobile network in the US. We will continue monitoring the service for some time to ensure a full recovery. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 14:54 PDT
      Update
      We are still observing recovery in SMS delivery receipt messages over a subset of short codes to T-Mobile network in the US. We will continue monitoring the service for some time to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 12:57 PDT
      Update
      We are still observing recovery in SMS delivery receipt messages over a subset of short codes to T-Mobile network in the US. We will continue monitoring the service for some time to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 10:53 PDT
      Monitoring
      We are observing recovery in SMS delivery receipt messages over a subset of short codes to T-Mobile network in the US. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 08:36 PDT
      Update
      We are still experiencing delivery receipt delays over a subset of short codes to T-Mobile network in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 01:46 PDT
      Update
      We are still experiencing delivery receipt delays over a subset of short codes to T-Mobile network in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Aug 01, 2022 - 01:48 PDT
      Update
      We are still experiencing delivery receipt delays over a subset of short codes to T-Mobile network in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jul 31, 2022 - 01:00 PDT
      Update
      We are still experiencing delivery receipt delays over a subset of short codes to T-Mobile network in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted Jul 30, 2022 - 09:00 PDT
      Update
      We are continuing to experience delays in receiving message delivery reports when sending to T-Mobile Network In US over a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Jul 30, 2022 - 01:07 PDT
      Update
      We are continuing to experience delays in receiving message delivery reports when sending to T-Mobile Network In US over a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jul 29, 2022 - 21:11 PDT
      Update
      We are continuing to experience delays in receiving message delivery reports when sending to T-Mobile Network In US over a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 29, 2022 - 19:11 PDT
      Update
      We are experiencing delays in receiving message delivery reports when sending to T-Mobile Network In US over a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 29, 2022 - 18:11 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery receipt delays to T-Mobile Network In US over a subset of short codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jul 29, 2022 - 18:01 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America, SMS Delivery Notifications & Status Callbacks).