Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Duplicates from a subset of Twilio Toll Free Numbers
Incident Report for Twilio
Resolved
We are no longer observing issues with MMS delivery on Twilio Toll Free numbers. This incident has been resolved.
Posted Oct 17, 2020 - 13:23 PDT
Monitoring
We are observing successful MMS delivery on Twilio Toll Free numbers after implementing a change. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 17, 2020 - 11:45 PDT
Update
We are observing duplicates for a subset of MMS messages sent from Twilio Toll Free numbers. Our engineering team is investigating the issue and we will provide an update in 1 hour or as soon as we have more information.
Posted Oct 17, 2020 - 10:48 PDT
Investigating
Our monitoring systems have detected a potential issue sending MMS messages with Twilio Toll Free numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 17, 2020 - 10:32 PDT
This incident affected: PROGRAMMABLE MESSAGING (MMS).