Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound SMS delays towards Twilio UK Mobile Numbers
Incident Report for Twilio
Resolved
Our carrier partner has resolved the issue. All systems are operating normally.
Posted 7 months ago. Jun 12, 2018 - 15:48 PDT
Update
Our carrier partner continues to work on resolving the delays in inbound messages towards Twilio UK Mobile Numbers. Next update in 1 hour.
Posted 7 months ago. Jun 12, 2018 - 14:38 PDT
Investigating
We have detected delays in inbound messages towards Twilio UK Mobile Numbers. We are working with our carrier partner to resolve the issue as quickly as possible. We will provide next update in 30 minutes.
Posted 7 months ago. Jun 12, 2018 - 14:05 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).