Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound Voice Issues to Canadian Numbers
Incident Report for Twilio
Resolved
This incident is now resolved.
Posted 8 months ago. May 23, 2018 - 13:52 PDT
Monitoring
We have not seen a recurrence of the inbound voice issues which impacted phone numbers in Edmonton area codes. We are continuing to monitor.
Posted 8 months ago. May 23, 2018 - 12:38 PDT
Investigating
We are experiencing inbound voice issues when dialing Canadian phone numbers. Oncall team is responding
Posted 8 months ago. May 23, 2018 - 12:10 PDT
This incident affected: PROGRAMMABLE VOICE (PSTN).