Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays on US T-mobile From a Subset of Shortcodes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery report delays when sending to US T-Mobile from a subset of shortcodes. This incident has been resolved.
      Posted Apr 26, 2021 - 02:43 PDT
      Monitoring
      We are observing recovery in MMS delivery report delays when sending to US T-Mobile from a subset of shortcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Apr 26, 2021 - 01:46 PDT
      Update
      We continue to experience MMS delivery delays to US T-Mobile from a subset of shortcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Apr 25, 2021 - 23:08 PDT
      Update
      We continue to experience MMS delivery delays to US T-Mobile from a subset of shortcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Apr 25, 2021 - 21:09 PDT
      Investigating
      We are experiencing MMS delivery delays to US T-mobile from a subset of shortcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Apr 25, 2021 - 20:11 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).