Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Report Delays to US Carriers on a Subset of Twilio Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery report delays when sending to US Carrier Networks on a Subset of Twilio Short Codes. This incident has been resolved.
      Posted Nov 13, 2020 - 00:21 PST
      Monitoring
      We are observing recovery in delivery report delays when sending to US Carrier Networks on a Subset of Twilio Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 12, 2020 - 22:57 PST
      Update
      We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 12, 2020 - 19:14 PST
      Investigating
      We are experiencing delays in receiving message delivery reports when sending to US Carrier Networks on a Subset of Twilio Short Codes. Message delivery is not affected. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 12, 2020 - 17:13 PST