Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound SMS delivery failures to Iran IR-MCI
Incident Report for Twilio
Resolved
We are observing full recovery on outbound SMS delivery to Iran IR-MCI. This incident is now resolved.
Posted Jul 02, 2020 - 09:18 PDT
Monitoring
We are observing recovery on outbound SMS delivery to Iran IR-MCI. We will continue to monitor this situation and will provide an update as soon as more information becomes available.
Posted Jul 02, 2020 - 08:29 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jul 02, 2020 - 07:54 PDT
Update
We are seeing outbound SMS delivery failures to Iran IR-MCI. This is affected a small subset of our customers. Our engineers are working to resolve the issue. We will provide more information as it is received.
Posted Jul 02, 2020 - 07:10 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 02, 2020 - 06:53 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).