Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Toll-Free Numbers in the U.S.
Incident Report for Twilio
Resolved
All systems are operating normally and DLR backlog processing is progressing.
Posted 7 months ago. Jul 20, 2018 - 12:30 PDT
Monitoring
Inbound and outbound toll-free messages are being delivered without delay. We continue to observe delays in delivery receipts (DLRs), however our carrier partner is processing the backlog and expects it to complete this evening (US Pacific Time).
Posted 7 months ago. Jul 20, 2018 - 12:14 PDT
Update
We are observing inbound and outbound toll-free message latency improvements. Messages are currently delayed by 1-3 minutes. We do not observe recovery in delivery receipt latency. We will provide an update when we observe further recovery.
Posted 7 months ago. Jul 20, 2018 - 10:48 PDT
Update
Our carrier partner has identified the root cause of the issue and is working to restore service to inbound and outbound toll-free messages in the United States. We will provide the next update when we see recovery.
Posted 7 months ago. Jul 20, 2018 - 09:54 PDT
Update
We continue to work with our carrier partner to resolve the delays impacting inbound and outbound messages between toll-free numbers in the United States. We will provide an update as quickly as possible.
Posted 7 months ago. Jul 20, 2018 - 08:10 PDT
Investigating
We are experiencing delivery delays for inbound and outbound messages between toll-free numbers in the United States. We are working with our carrier partner to resolve the issue.
Posted 7 months ago. Jul 20, 2018 - 06:58 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).