Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays Sending Short Code SMS to T-Mobile Subscribers
Incident Report for Twilio
Resolved
The Carrier has resolved the issue. Our monitoring has confirmed that short code delivery speed to T-Mobile handsets is back to normal.
Posted 9 months ago. Apr 12, 2018 - 10:11 PDT
Identified
We have detected delays of up to 5 minutes delivering messages to T-Mobile subscribers from some US short codes. We have escalated to the carrier and they are actively working to resolve the issue.
Posted 9 months ago. Apr 12, 2018 - 09:55 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).