Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays from Shortcodes to Multiple US Networks
Incident Report for Twilio
Resolved
Issues with SMS delivery delays when sending messages to multiple US networks has been resolved and SMS is operating normally at this time.
Posted May 04, 2021 - 08:33 PDT
Update
We continue to observe recovery in SMS delivery delays when sending messages to multiple US networks over a very small subset of short codes. We are continuing to monitor the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 04, 2021 - 07:20 PDT
Update
We continue to observe recovery in SMS delivery delays when sending messages to multiple US networks over a very small subset of short codes. We are continuing to monitor the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 04, 2021 - 05:30 PDT
Monitoring
We are observing recovery in SMS delivery delays when sending messages to multiple US networks over a very small subset of short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 04, 2021 - 03:30 PDT
Update
We are continuing to work with our carrier partner to resolve SMS delivery delays when sending messages to multiple US networks over a very small subset of short codes. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted May 03, 2021 - 19:34 PDT
Update
We are continuing to work with our carrier partner to resolve SMS delivery delays when sending messages to multiple US networks over a very small subset of short codes. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted May 03, 2021 - 15:29 PDT
Update
We are continuing to work with our carrier partner to resolve SMS delivery delays when sending messages to multiple US networks over a very small subset of short codes. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 03, 2021 - 13:35 PDT
Identified
Upon further investigation, we identified that the SMS delivery delay issue is limited to a very small subset of short codes. SMS messages from affected short codes to multiple mobile networks could be delayed up to a couple of minutes. We have started observing recovery in the past hour, while the delivery report could still be delayed. We are actively working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 03, 2021 - 12:28 PDT
Update
We are still experiencing SMS delivery delays when sending messages to multiple US networks. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted May 03, 2021 - 10:15 PDT
Update
We are still experiencing SMS delivery delays when sending messages to multiple US networks. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 03, 2021 - 08:16 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to multiple US networks. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 03, 2021 - 07:16 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).