Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Issues With New Customers Changing Currency from USD
      Incident Report for Twilio
      Resolved
      The issue with new customers not being able to change their currency settings away from USD currency, in Twilio Console has been resolved. Customers creating trial accounts can now change their default Currency away from USD.
      Posted Mar 16, 2023 - 13:08 PDT
      Update
      We are investigating a potential issue with new customers being able to change their currency settings away from USD currency, in Twilio Console. Our engineering team is actively investigating. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Mar 16, 2023 - 12:30 PDT
      Investigating
      Our monitoring systems have detected a potential issue with new customers being able to change their currency settings away from USD currency, in Twilio Console. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 16, 2023 - 12:19 PDT
      This incident affected: TWILIO PLATFORM (Billing).