Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays to O2 network in Germany
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery report delays when sending to O2 network in Germany. This incident has been resolved.
      Posted Aug 01, 2022 - 07:41 PDT
      Monitoring
      We are observing recovery in SMS delivery report to O2 network in Germany. We will continue monitoring the service to ensure a full recovery. We will provide another update in the next 2 hours or as soon as more information becomes available.
      Posted Aug 01, 2022 - 05:41 PDT
      Investigating
      We are experiencing SMS delivery report delays to O2 network in Germany. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 01, 2022 - 04:40 PDT
      This incident affected: CARRIER NETWORK (SMS, Europe).