Twilio Verify was degraded for 29 minutes between 16:05 and 16:34 Pacific Time on 02/28/2025. During this period of time customers may have experienced elevated HTTP 500 and 503 status codes on the create, check, update, and fetch Verifications endpoints of the Twilio Verify API. The issue has now been resolved.
Posted Feb 28, 2025 - 17:13 PST
Monitoring
There were elevated HTTP 500 and 503 status codes on the create, check, update, and fetch Verifications endpoints have resolved and Twilio Verify API is operating normally at this time.
Posted Feb 28, 2025 - 17:07 PST
Update
We are investigating a service interruption with the Twilio Verify API where we are experiencing elevated HTTP 500 and 503 status codes on the create, check, update, and fetch Verifications endpoint. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Feb 28, 2025 - 17:00 PST
Investigating
Our monitoring systems have detected a potential issue causing elevated HTTP 500 and 503 status codes on the create, check, update, and fetch Verifications endpoints of the Verify API. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 28, 2025 - 16:55 PST
This incident affected: DEVELOPER TOOLS (REST API).