Super SIM network connectivity issues have been resolved and is operating normally at this time.
Posted Mar 16, 2023 - 03:38 PDT
Update
[Since 06:15 UTC] We are investigating an issue affecting less than 5% of devices using Super SIM, which may result in delays when connecting to the network. Devices with an existing data connection are not impacted; however, they may experience delays if they attempt to re-establish the data connection. Our engineering team is actively collaborating with the affected network provider to resolve this issue. We will provide a further update within 2 hours or sooner, as more information becomes available.
Posted Mar 16, 2023 - 02:27 PDT
Update
[Since 06:15 UTC] We are investigating an issue affecting less than 5% of devices using Super SIM, which may result in delays when connecting to the network. Devices with an existing data connection are not impacted; however, they may experience delays if they attempt to re-establish the data connection. Our engineering team is actively collaborating with the affected network provider to resolve this issue. We will provide a further update within 1 hour or sooner, as more information becomes available.
Posted Mar 16, 2023 - 01:35 PDT
Investigating
We've become aware of a potential issue with Super SIM. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 16, 2023 - 01:14 PDT
This incident affected: INTERNET OF THINGS (Super SIM).