Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound PSTN calls to some Singapore and Indonesia phone numbers have increased latency
Incident Report for Twilio
Resolved
The incident has been resolved now.
Posted 13 days ago. Oct 07, 2019 - 08:32 PDT
Monitoring
Inbound PSTN voice calls to Singapore and Indonesia phone numbers are now operating as expected. We continue to monitor the situation.
Posted 13 days ago. Oct 07, 2019 - 06:41 PDT
Update
Inbound PSTN voice calls to Singapore and Indonesia phone numbers are now operating but with increased latency. We continue to work with our partners to resolve the incident and will provide an update when we have further information.
Posted 13 days ago. Oct 07, 2019 - 02:14 PDT
Investigating
Inbound voice calls to approximately 10% of Singapore numbers on our network are failing. We are investigating and working with our partners. We will provide an update when we have further information.
Posted 14 days ago. Oct 06, 2019 - 23:14 PDT
This incident affected: CARRIER NETWORK (Voice, APAC).