Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Retrieval of messages information is delayed
      Incident Report for Twilio
      Resolved
      All message information is caught up.
      Posted May 03, 2016 - 16:53 PDT
      Update
      The team is processing messages sent on 5/2/2016 between 8am and 11:30am PDT. This will continue through 5/3/2016. We will post another update when all messages are caught up.
      Posted May 02, 2016 - 21:31 PDT
      Update
      The team is processing messages sent on 5/2/2016 between 8am and 11:30am PDT. This will continue through 5/3/2016. We will post another update when all messages are caught up.
      Posted May 02, 2016 - 21:29 PDT
      Monitoring
      The team has identified the issue and resolved the delays for new messages and the ability to delete messages. The Rest API and Console are operational again for new messages. Messages that were sent between 8:00am and 11:30am PDT will be delayed from appearing in the RestAPI and Console by another 5-9 hrs. We will post another update when all messages are caught up.
      Posted May 02, 2016 - 11:46 PDT
      Update
      We are experiencing a delay in message retrieval in the REST API and Console. Delete messages through the REST API are also impacted. The team is continuing to investigate. We will provide another update in 30 minutes.
      Posted May 02, 2016 - 11:00 PDT
      Update
      We are experiencing a delay in message retrieval in the REST API and Console. Delete messages through the REST API are also impacted. The team is continuing to investigate. We will provide another update in 30 minutes.
      Posted May 02, 2016 - 10:31 PDT
      Update
      We are experiencing a delay in message retrieval from the REST API and Console. Delete messages through the REST API are also impacted. The team is continuing to investigate. We will provide another update in 30 minutes.
      Posted May 02, 2016 - 09:59 PDT
      Update
      The team continues to investigate delays in the retrieval of messages information from the /messages API for some customers. We will provide another update in 30 minutes.
      Posted May 02, 2016 - 09:31 PDT
      Update
      The team is investigating delays in the retrieval of messages information from the /messages API for some customers. Inbound and outbound SMS are functioning properly. We will provide another update in 30 minutes.
      Posted May 02, 2016 - 09:01 PDT
      Investigating
      We are experiencing some delay with inbound and outbound sms messages and some requests to the /messages API may be delayed or fail. Our engineering team is investigating and we will provide another update in 30 minutes.
      Posted May 02, 2016 - 08:30 PDT
      This incident affected: DEVELOPER TOOLS (Console, REST API), CARRIER NETWORK (SMS Short Code, North America), and PROGRAMMABLE MESSAGING (MMS, SMS).