Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures to Iran
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery failures to Iran. This incident has been resolved.
      Posted May 12, 2020 - 12:39 PDT
      Update
      We are continuing to investigate this issue.
      Posted May 12, 2020 - 10:30 PDT
      Update
      We are continuing to investigate this issue.
      Posted May 12, 2020 - 09:54 PDT
      Investigating
      We are experiencing delivery failures sending to the MCI network in Iran. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted May 12, 2020 - 06:21 PDT