Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delivery Receipt Delays for SMS from a Subset of US Short Codes towards US Cellular in the USA
Incident Report for Twilio
Resolved
We are no longer experiencing delivery receipt delays for short code messages sent towards US Cellular network in the USA. This incident has been resolved.
Posted Jan 11, 2020 - 11:26 PST
Monitoring
We are seeing signs of recovery on delivery receipts for the short code messages towards US Cellular. We will continue to monitor and provide another update shortly.
Posted Jan 11, 2020 - 10:41 PST
Investigating
We are experiencing delays in receiving delivery receipts for a subset of short code messages sent towards US Cellular network in the USA. Actual delivery of messages is unaffected. We are working with our carrier partners to resolve this issue. We will provide further updates, as they become available.
Posted Jan 11, 2020 - 10:00 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America).