Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery to Telcel customers in Mexico is currently degraded
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 3 months ago. Jan 25, 2019 - 00:12 PST
Investigating
SMS to Telcel customers in Mexico is currently degraded. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted 3 months ago. Jan 24, 2019 - 22:17 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).