Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Call Quality issues to a Subset of Twilio North America Tollfree Numbers
Incident Report for Twilio
Resolved
We experienced call quality issues for calls to subset of Twilio North America Tollfree Numbers between 6:00am PT to 8:30am PT. Twilio’s carrier partner had an issue with network equipment that caused the call quality issue. Carrier partner rerouted traffic from the problematic equipment to resolve the issue. The service has been restored and calls to Twilio North America Tollfree Numbers are working normally.
Posted Jul 20, 2020 - 11:57 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 20, 2020 - 08:51 PDT