Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Degradation From US Short Codes
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Nov 22, 2019 - 14:00 PST
      Investigating
      We are currently observing intermittent MMS message delivery delays and duplication originating from a subset of short codes in the US. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Nov 22, 2019 - 11:08 PST
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).