Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound Call Failures when Caller ID is set to anonymous
Incident Report for Twilio
Resolved
We are continuing to work with T-Mobile to resolve failing outbound calls made with the Caller ID set to anonymous. We will be reaching out to impacted customers with a solution. This incident is resolved.
Posted Mar 27, 2020 - 12:54 PDT
Identified
Our engineers have identified failing outbound calls made to T-Mobile in the US when the Caller ID is set to anonymous. We are actively working with our carrier partners to allow anonymous calling and will update as soon as we have more information.
Posted Mar 27, 2020 - 09:27 PDT
Update
Our engineers continue to work with our carrier partners to allow anonymous calling. We will provide an update as soon as we have more information.
Posted Mar 27, 2020 - 09:13 PDT
Update
Our engineers are actively working with our carrier partners to allow anonymous calling. We will provide an update as soon as we have more information.
Posted Mar 26, 2020 - 22:31 PDT
Update
We have received reports that when the caller ID is set to anonymous, calls are being rejected. We are actively working with our carrier partners to allow anonymous calling and will update as soon as we have more information.
Posted Mar 26, 2020 - 18:45 PDT
Investigating
Our monitoring systems have detected a potential issue when the caller ID is set to anonymous. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 26, 2020 - 14:40 PDT
This incident affected: CARRIER NETWORK (Voice, North America).