The issue affecting low balance notifications and the automatic balance recharge feature has been resolved and is operating normally at this time.
Posted May 13, 2026 - 04:23 PDT
Update
Our engineers have implemented a fix and we are now seeing billing processing as expected. We continue monitoring system performance and will provide another update in 8 hours or as soon as more information becomes available.
Posted May 13, 2026 - 01:54 PDT
Update
Our engineers have implemented a fix and we are now seeing billing processing as expected. We continue monitoring system performance and will provide another update in 4 hours or as soon as more information becomes available.
Posted May 12, 2026 - 21:54 PDT
Update
Our engineers have implemented a fix and we are now seeing billing processing as expected. We continue monitoring system performance and will provide another update in 4 hours or as soon as more information becomes available.
Posted May 12, 2026 - 18:03 PDT
Update
Our engineers have implemented a fix and we are now seeing billing processing as expected. We continue monitoring system performance and will provide another update in 2 hours or as soon as more information becomes available.
Posted May 12, 2026 - 16:02 PDT
Update
Our engineers have implemented a fix and we are now seeing billing processing as expected. We continue monitoring system performance and will provide another update in 2 hours or as soon as more information becomes available.
Posted May 12, 2026 - 14:01 PDT
Monitoring
Our engineers have implemented a fix and we are now seeing billing processing as expected. We are monitoring system performance and will provide another update in 2 hours or as soon as more information becomes available.
Posted May 12, 2026 - 12:05 PDT
Identified
Our engineering team has identified an issue affecting customer low balance notifications and the automatic balance recharge feature. We are actively working to deploy a fix. We will provide an update in 1 hour, or sooner if additional information becomes available.
Posted May 12, 2026 - 11:24 PDT
Update
We are still investigating an issue affecting customer low balance notifications and the automatic balance recharge feature. We are actively working to deploy a fix. We will provide an update in 2 hours, or sooner if additional information becomes available.
Posted May 12, 2026 - 11:05 PDT
Update
Our engineering team has identified an issue affecting customer low balance notifications and the automatic balance recharge feature. We are actively working to deploy a fix. We will provide an update in 1 hour, or sooner if additional information becomes available.
Posted May 12, 2026 - 10:29 PDT
Investigating
Our monitoring systems have detected a potential issue with Credit cards will not be charged for PAYG. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted May 12, 2026 - 10:09 PDT
This incident affected: TWILIO PLATFORM (Billing).