Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound MMS and DLR delays from Sprint US handsets
      Incident Report for Twilio
      Resolved
      The carrier has confirmed that they experienced an issue on their platform. We are now observing immediate and stable delivery for Inbound MMS and DLRs on Sprint. All services are operating normally at this time
      Posted Sep 19, 2018 - 11:58 PDT
      Monitoring
      We are observing recovery for Inbound MMS and DLR delays from Sprint US handsets. Our engineering teams will continue to monitor and provide an update as soon as possible
      Posted Sep 19, 2018 - 11:20 PDT
      Investigating
      We are observing delays in receiving delivery receipts (DLRs) and Inbound MMS from Sprint handsets for both US Short Codes and Long Codes. Our engineering team is actively working with our partner to get the issues resolved. We will provide update as soon as possible.
      Posted Sep 19, 2018 - 09:36 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (MMS).