Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Re-purchasing a recently released number via the console results in a ‘something went wrong’ error.
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Mar 31, 2020 - 14:52 PDT
      Monitoring
      A fix has been implemented and we are monitoring the results.
      Posted Mar 31, 2020 - 12:00 PDT
      Identified
      The issue has been identified and a fix is being implemented.
      Posted Mar 31, 2020 - 11:42 PDT
      Update
      Customers who attempt to re-purchase recently released phone numbers through the Twilio console are experiencing generic errors and as a result are unable to complete the purchase flow. Our engineers are working to fix the issue as soon as possible. We will provide more information as it is received.
      Posted Mar 31, 2020 - 10:47 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 31, 2020 - 10:40 PDT
      This incident affected: DEVELOPER TOOLS (Console) and PHONE NUMBERS.