Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
API 500 Errors Affecting Multiple Services
Incident Report for Twilio
Resolved
We have fully monitored the API 500 errors affecting multiple services and have not observed any further issues. All services are operating normally at this time.
Posted Nov 09, 2020 - 16:19 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 09, 2020 - 12:41 PST
Monitoring
We experienced 500 errors when reaching parts of our API today between 11:43am PST - 11:53am PST. Issues customers may have experienced:

- No debugger notifications for failed voice calls
- Pinned products on console sidebar missing or non-functional
- Phone number configuration page shows error message
- TwiMLbin apps return 500s
- Video rooms could not be created

We are no longer experiencing the 500 errors but continue to monitor the situation. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 09, 2020 - 12:28 PST
Update
We are continuing to investigate this issue.
Posted Nov 09, 2020 - 12:15 PST
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 09, 2020 - 11:57 PST
This incident affected: PROGRAMMABLE VIDEO (Group Rooms, Peer-to-Peer Rooms), SERVERLESS (TwiML Bins), TWILIO PLATFORM (Debugger & Alerts, Console), and PHONE NUMBERS.