All services impacted by an issue with Twilio Rest API have recovered and are operating as intended. This incident has been resolved.
Posted Aug 17, 2023 - 19:44 PDT
Monitoring
We are observing recovery with the Twilio Rest API issue impacting multiple Twilio services: Messaging, CDX, Studio and Flex. We will be monitoring all services to ensure full recovery and provide another update in 30 minutes or as soon as more information becomes available.
Posted Aug 17, 2023 - 19:24 PDT
Update
We are experiencing an issue with the Twilio Rest API, impacting multiple Twilio services: Messaging, CDX, Studio and Flex. For Messaging, Verify SMS and WhatsApp is experiencing degradation in several countries and there are elevated API latency, delayed and failed messages for MMS and SMS. For Studio, some customers may experience failures in widgets that sending messages. For Flex, the ability to send and receive messages are impacted. Our engineering team is actively working to resolve the issue. We expect to provide another update in 30 mins or as soon as more information becomes available.
Posted Aug 17, 2023 - 19:14 PDT
Identified
We are experiencing an issue with the Twilio Rest API, impacting multiple Twilio services: Messaging, CDX, Studio and Flex. For Messaging, Verify SMS and WhatsApp is experiencing degradation in several countries and there are elevated API latency, delayed and failed messages for MMS and SMS. For Studio, some customers may experience failures in widgets that sending messages. For Flex, the ability to send and receive messages are impacted. Our engineering team is actively working to resolve the issue. We expect to provide another update in 30 mins or as soon as more information becomes available.
Posted Aug 17, 2023 - 18:44 PDT
Update
We are experiencing an issue with the Twilio Rest API, impacting multiple Twilio services: Flex, CDX, and Messaging. For Flex, the ability to send and receive messages are impacted. Studio is still operational but some customers may experience failures in widgets that sending messages. For Messaging, Verify SMS and WhatsApp is experiencing degradation in several countries and there are elevated API latency, delayed and failed messages for MMS and SMS. Our engineering team is actively working to resolve the issue. We expect to provide another update in 30 mins or as soon as more information becomes available.
Posted Aug 17, 2023 - 18:35 PDT
Update
We are experiencing an issue with the Twilio Rest API, impacting multiple Twilio services: Voice, Flex, CDX, and Messaging. Our engineering team is actively working to resolve the issue. We expect to provide another update in 30 mins or as soon as more information becomes available.
Posted Aug 17, 2023 - 18:16 PDT
Update
We are experiencing an issue impacting SMS, MMS, Voice, Verify, Flex, and Proxy. Our engineering team is actively working to resolve the issue. We expect to provide another update in 30 mins or as soon as more information becomes available.
Posted Aug 17, 2023 - 17:46 PDT
Investigating
We've become aware of a potential issue with SMS, MMS, Flex Messaging, and Verify. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Aug 17, 2023 - 17:14 PDT
This incident affected: SERVERLESS (Studio), ACCOUNT SECURITY (Verify), FLEX (Flex Conversations, Proxy), PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Services), and PROXY.