Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS short code delivery degradation towards US Verizon
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 25 days ago. Sep 25, 2019 - 15:34 PDT
Monitoring
We are observing signs of recovery with message delivery to Verizon handsets. We continue to work with our carrier partner to restore service. We will provide further updates as we gain more information.
Posted 25 days ago. Sep 25, 2019 - 14:53 PDT
Investigating
We’re currently investigating an issue with degradation in SMS deliverability from a subset of Twilio Short Codes to Verizon handsets. We’re working with our carrier partners to resolve this issue. We will provide further updates, as they become available.
Posted 25 days ago. Sep 25, 2019 - 12:44 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).