Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Mobilink & Jazz Networks in Pakistan
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Mobilink & Jazz Networks in Pakistan. This issue has been resolved.
      Posted Nov 29, 2022 - 14:26 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Mobilink & Jazz Networks in Pakistan. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 12:28 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Mobilink & Jazz Networks in Pakistan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 12:13 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Mobilink & Jazz Networks in Pakistan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 10:11 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to Mobilink & Jazz Networks in Pakistan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 29, 2022 - 09:11 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).