Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Report Delays to US and Canada Networks
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery report delays when sending to US and Canada networks from a subset of Twilio long codes. This incident has been resolved.
      Posted Sep 30, 2022 - 01:02 PDT
      Monitoring
      We are observing recovery in delivery report delays when sending to US and Canada networks from a subset of Twilio long codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 29, 2022 - 23:08 PDT
      Update
      We are experiencing delays in receiving MMS delivery reports when sending to US and Canada networks from a subset of Twilio long codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Sep 29, 2022 - 17:43 PDT
      Update
      We are experiencing delays in receiving MMS delivery reports when sending to US and Canada networks from a subset of Twilio long codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Sep 29, 2022 - 13:43 PDT
      Update
      We are still experiencing delays in receiving MMS delivery reports when sending to US networks from a subset of Twilio long codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 29, 2022 - 11:56 PDT
      Update
      We are experiencing delays in receiving MMS delivery reports when sending to US networks from a subset of Twilio long codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 29, 2022 - 11:16 PDT
      Investigating
      Our monitoring systems have detected a potential issue with MMS delivery report delays to all US networks for a subset of Twilio long codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 29, 2022 - 11:10 PDT
      This incident affected: CARRIER NETWORK (MMS Long Code, North America, SMS Delivery Notifications & Status Callbacks).