Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays in US
Incident Report for Twilio
Resolved
MMS issue is resolved. All systems operating normally.
Posted 9 days ago. Feb 08, 2019 - 18:30 PST
Monitoring
We have observed recovery in delays delivering outbound and inbound MMS over a subset of US short codes and 10-digit long codes. We’ll continue to monitor.
Posted 9 days ago. Feb 08, 2019 - 18:16 PST
Update
We are continuing to investigate this issue.
Posted 10 days ago. Feb 08, 2019 - 16:04 PST
Investigating
We are observing delays in delivering outbound and inbound MMS over a subset of US short codes and over some 10-digit long code numbers. Our engineers are actively working with our carrier partners to get the issue resolved.
Posted 10 days ago. Feb 08, 2019 - 13:47 PST
This incident affected: CARRIER NETWORK (MMS Long Code, North America, MMS Short Code, North America) and PROGRAMMABLE MESSAGING (MMS).