The incident has been resolved and SMS delivery receipts from a subset of Twilio Long Codes and Short Codes to Verizon and Clearsky network subscribers in the United States are operating normally.
Posted Mar 09, 2026 - 22:58 PDT
Monitoring
We have observed a recovery in SMS delivery receipts from a subset of Twilio Long Codes and Short Codes to Verizon and Clearsky network subscribers in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 09, 2026 - 21:05 PDT
Investigating
Twilio customers may be experiencing SMS delivery delays from Subset Of Twilio Long Code to Verizon & Clearsky Network In United States . Our team is actively investigating this issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 09, 2026 - 20:02 PDT
This incident affected: CARRIER NETWORK (SMS Long Code, North America).